Jump to content
×
×
  • Create New...
  • 0

Un " Z" et mon "Q"


Go to solution Solved by HawK-EyE,

Question

Oui donc j'imagine que je ne dois pas être le seul mais je pose la question, quelqu'un aurait trouvé une solution pour corriger le fait que en mode construction on ne puissent plus utiliser les touches "Z" et " Q" ?

Car bon, du coup je m'interdis la construction ~ :563e4c631b1f7_63060_1copie:

Link to post
Share on other sites

14 answers to this question

Recommended Posts

  • 1
  • Solution

Attention !

Pour que autohotkey fonctionne, il faut laisser les contrôles par défaut dans le menu de Fo4 (W pour avancer, A pour la gauche et Q pour le vats, etc...).

 

Pour télécharger autohotkey

http://ahkscript.org/download/ahk-install.exe

  1. Installez le logiciel autohokey via le lien ci dessus
  2. Copiez le contenu du fichier ci dessous dans un fichier texte.
  3. Renommez le fichier texte en "Fallout4.ahk"
  4. Sur le fichier Fallout4.ahk faites clic-droit "run script"
  5. Dans Fallout4, pour que les contrôles d'autohotkey soient pris en compte, vous devez remettre les contrôles par défaut.

 

Voici le fichier que j'utilise : fo4.ahk

Citation

#NoEnv  ; Recommended for performance and compatibility with future AutoHotkey releases.

; #Warn  ; Enable warnings to assist with detecting common errors.
SendMode Input  ; Recommended for new scripts due to its superior speed and reliability.
SetWorkingDir %A_ScriptDir%  ; Ensures a consistent starting directory.
 
#IfWinActive, ahk_class Fallout4
 
; Default Azerty controls
z::w                    ; Forward
s::s                    ; Back
q::a                    ; Strafe Left
d::d                    ; Strafe Right
LButton::LButton        ; Attack
RButton::RButton        ; Aim/Block
~Alt::Alt               ; Bash/Powerattack/Grenade
e::e                    ; Activate
r::r                    ; Reload
Tab::Tab                ; Pip-boy
MButton::MButton        ; Change POV/Workshop
v::v                    ; Change POV/Workshop (bis)
Space::Space            ; Jump
~Shift::Shift           ; Sprint
a::q                    ; VATS
LCtrl::LCtrl            ; Sneak
c::c                    ; Run/Walk
CapsLock::CapsLock      ; Toggle Run/Walk
x::x                    ; Automove
f::f                    ; Favorites
F5::F5                  ; Quicksave
F9::F9                  ; Quickload
Esc::Esc                ; Pause
k::k                    ; Stats
i::i                    ; Inventory
j::j                    ; Data
m::m                    ; Map
o::o                    ; Radio

 

 

 

Et voilà, il est possible de se déplacer correctement dans le menu de construction.

Edited by HawK-EyE
Link to post
Share on other sites
  • 0

Voilà la solution que j'ai trouvée : en jeu, j'ai passé mon clavier en qwerty (avec le raccouci Maj+Alt) puis j'ai reconfiguré les touches à ma sauce dans les Options, ça marche ensuite correctement.
La contrainte c'est que je dois de nouveau faire Maj+Alt quand je relance le jeu pour retrouver mes commandes.

Link to post
Share on other sites
  • 0
Il y a 2 heures, Aleck a dit :

Oui donc j'imagine que je ne dois pas être le seul mais je pose la question, quelqu'un aurait trouvé une solution pour corriger le fait que en mode construction on ne puissent plus utiliser les touches "Z" et " Q" ?

Car bon, du coup je m'interdis la construction ~ :563e4c631b1f7_63060_1copie:

J'utilise la touche X (déplacement automatique) pour avancer.

Pour le reste, je fait des clics de souris.

 

Sinon la solution de Bergil est valable :

il y a une heure, Bergil a dit :

Voilà la solution que j'ai trouvée : en jeu, j'ai passé mon clavier en qwerty (avec le raccouci Maj+Alt) puis j'ai reconfiguré les touches à ma sauce dans les Options, ça marche ensuite correctement.
La contrainte c'est que je dois de nouveau faire Maj+Alt quand je relance le jeu pour retrouver mes commandes.

 

Link to post
Share on other sites
  • 0

Et bien oui j'ai utilisé quelque minutes la touche X pour avancer mais ça deviens vite galère ~ et bizarrement je ne peux pas passer mon jeu en QWERTY hum...

EDIT: j'ai réussi à le passer en mode qwerty :] Merci beaucoup pour vos réponses !

Edited by Aleck
Link to post
Share on other sites
  • 0

Alors, la solution de Bergil est la meilleure jusqu'à présent (voire la seule). Mais combien de fois ne me suis=je pas fait exploser avec ça...

 

Je viens sur le forum écrire un truc, puis je retourne sur le jeu, j'appuie sur Z, je n'avance pas, j'appuie alors sur Alt-Shift et boum, je lance une grenade à cause de la touche Alt et pris de panique, je ne sais pas sur quelle touche appuyer pour me dégager, du coup, j'explose.

 

Comment a-t-on pu faire un système aussi (censuré)???

Link to post
Share on other sites
  • 0
il y a 27 minutes, HawK-EyE a dit :

Pour que autohotkey fonctionne, il faut laisser les contrôles par défaut dans le menu de Fo4 (W pour avancer, A pour la gauche et Q pour le vats, etc...).

La petite phrase qu'il manquait (ou plus certainement a laquelle je n'avais pas fait attention) et qui change tout. Ca fait 2 jours que j'ai installé le autohotkey et il ne fonctionnait pas, je comprenais pas pourquoi.

Merci !

Link to post
Share on other sites
  • 0

Très sympathique ce petit logiciel pour contourner ce bug gênant du mode construction (qui m'a couper l'envie de m'y intéresser en attendant un éventuel patch) mais pour configurer nos touches après c'est dans le fichier "fallout4.ahk" ou on peut reconfigurer dans le menu du jeu ?

Link to post
Share on other sites
Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    No registered users viewing this page.