Jump to content
×
×
  • Create New...
  • 0

Lancement Fallout impossible


Question

Bonjour à tous,

 

Je tiens d'abord à vous remercier pour ce site très intéressant.

J'ai récemment acheté sur steam pendant les soldes le pack Fallout avec Fallout 1, 2 et tactic.

J'ai donc installé le 1 et le 2 mais il m'est impossible de les lancer (sur l'ordi, pas par la fenêtre bien sûr...). Je peux démarrer le launcher, mais dès que je mets play, le launcher se ferme et rien ne se passe.

J'ai essayé sans installer les patchs puis avec (le FixIT et celui pour le 2). Dans le dossier de base de steam, puis ailleurs. En modifiant les paramètres de compatibilité, en mode administrateur. En désinstallant et réinstallant. Rien ne change, le jeu ne démarre jamais.

Je suis sous windows 10 64bit (après maj à partir de windows 7). Les jeux viennent donc de steam.

Voilà, j'ai passé l'après midi à chercher une solution sur internet, je n'ai strictement rien trouvé qui fonctionne, et je vais bientôt finir par lancer l'ordi (par la fenêtre cette fois-ci...)

 

Merci pour votre aide.




Link to post
Share on other sites

25 answers to this question

Recommended Posts

  • 0

Salut @mkael ! 

Bienvenu sur Fogen. Tu as bien fais de venir nous voir. On va te le solutionner ton problème, il y a pas de raison ;)

Bon pour commencer : as tu suivi ce tuto :

Mis à jour régulièrement par Dr Gast. Si tu le suis à la lettre, il devrait fonctionner, il me semble avoir lui quelque part que pour les jeux steam il est nécessaire de les copier ou de les bouger pour que le fixt puisse fonctionner. Je te laisse vérifier. Reviens vers nous quand tu auras réussi ou non cette manipulation :).  

Link to post
Share on other sites
  • 0

Salut. Bienvenu !


La partie du tuto qui concerne Steam se trouve au début de l'étape 1 :

Citation

Etape 1 (Installation) :

Installez Fallout 1 (version CD, GoG ou Steam).
Choisissez une installation "complète" ("humongous") si demandé (selon la méthode d'installation).

Attention : Le répertoire d'installation par défaut de Steam est "C:\Steam\SteamApps\common\Fallout". Vous devrez déplacer manuellement le dossier "Fallout" dans C:\Games AVANT d'aller plus loin. Au besoin, créez le dossier Games.
N'oubliez pas de créer un raccourci pour remplacer les anciens qui sont devenus invalides suite au déplacement de l'exe du jeu.

 

Mais c'est bizarre que les jeux "Vanilla" (de base) n'aient pas voulu démarrer.

Si jamais, il te reste la solution de "l'installation manuelle", qui fonctionne à tous les coups (lire la suite de l'étape 1 du tuto).


Tiens nous au courant :)

Link to post
Share on other sites
  • 0

Merci à vous deux pour vos réponses.

J'avais en effet déjà suivi le tuto, et notamment la partie pour steam en déplaçant le dossier dans Games (seule différence est que le dossier steam se trouvait dans program files (x86) et non directement dans C:\). J'ai une question à ce propos, en déplaçant le dossier du jeu, il n'y a pas de problème avec les clés de registre du jeu ?

Je n'avais pas encore essayer la méthode manuelle, je vais télécharger les fichiers et essayer ça.

Petite précision, quand je lance l'executable (soit le falloutW.exe, soit le FalloutHR.exe), il s'affiche pendant 2 sec dans le gestionnaire de tache puis disparait. Si jamais je supprime des dossiers du jeu, ou si je met l'executable dans un autre dossier tout seul, il se produit la même chose (il s'affiche quelques sec dans le gestionnaire de tache et disparait), il ne se passe jamais rien, jamais de message d'erreur.

 

Dès que j'ai enfin réussi à télécharger les fichiers pour la version manuelle (ma connexion est pas très efficace...), je vous tiens au courant. Je reconnais que c'est très curieux que le jeu de base ne démarre même pas, je vais peut être essayer de contacter steam en parallèle.

Link to post
Share on other sites
  • 0
il y a 5 minutes, mkael a dit :

 

J'avais en effet déjà suivi le tuto, et notamment la partie pour steam en déplaçant le dossier dans Games (seule différence est que le dossier steam se trouvait dans program files (x86) et non directement dans C:\). J'ai une question à ce propos, en déplaçant le dossier du jeu, il n'y a pas de problème avec les clés de registre du jeu ?

 

C'est pour l'installation du FIXT, ils n'ont pas incorporer la possibilité de choisir le dossier cible. (en tout cas ça pose pb avec le fixt). Pour les clés, je ne pense pas, les clés sont rattachés à l'exe pas à l'emplacement du fichier ?

De mémoire, on lance le jeu par "Play fallout fixt" quand tu as le fixt. J'ai récuperer une install steam sur mon pc avec le fixt en installation manuelle je crois, il fonctionne mais quand je veux lancer par le launcher, il me met un message d'erreur demandant le MASTER.dat . J'ai la flemme de chercher mais le FIXT est grandement conseillé pour les machines modernes :)

Tient nous au jus.

Link to post
Share on other sites
  • 0

Tu as certainement raison pour les clés, je ne suis pas assez calé pour ça.

La version du FixIT que j'ai permet de choisir le dossier d'installation, c'est pour ça que j'ai essayé à la fois dans le dossier steam, puis j'ai désinstallé pour essayer dans le dossier Games, toujours même problème, même avec le Play fallout fixt.

Je vais voir en manuel.

Merci

Link to post
Share on other sites
  • 0
Citation

Pour les clés, je ne pense pas, les clés sont rattachés à l'exe pas à l'emplacement du fichier ?

Négatoire. Les clés de registres indique au système où se trouve telle ou telle chose. Mais elles ne sont pas réactives. Tu déplaces un truc comme un exécutable de jeu, la plupart du temps il va t'envoyer paître, surtout si c'est un jeu récent. Les jeux anciens dépendaient moins des clés de registres car ils utilisaient bien moins de bibliothèques systèmes (logique, elles n'existaient pas encore), le jeu n'utilisaient que ce qui était contenu dans son dossier racine.

Link to post
Share on other sites
  • 0

Bon, je viens de tester avec l'installation manuelle, donc en mettant les fichiers du tuto dans un dossier c:\Games\Fallout puis en installant le FixIT dans ce dossier, toujours rien.

Donc ça doit bien venir de mon pc, c'est bizarre j'ai jamais eu de soucis comme ça auparavant.

Je vais tester sur un autre ordi cet après midi pour voir.

 

(Et merci Eldrak pour l'info)

 

Edit : Je viens de tester l'installation manuelle sur un autre ordi qui a la même configuration (windows 10 64b mis à jour à partir de windows 7, même antivirus et pare feu (que j'ai désactivé pour essayer)), le jeu ne démarre pas du tout.

Je suis un peu démuni pour le coup....

Edited by mkael
Link to post
Share on other sites
  • 0
Il y a 4 heures, mkael a dit :

Edit : Je viens de tester l'installation manuelle sur un autre ordi qui a la même configuration (windows 10 64b mis à jour à partir de windows 7, même antivirus et pare feu (que j'ai désactivé pour essayer)), le jeu ne démarre pas du tout.

Je suis un peu démuni pour le coup....

Il faut faire attention à chaque détail du tuto, par exemple, au répertoire d'installation du Fixt (Fallout\Fallout Fixt ).

Ca sent quand-même l'installation foireuse, je trouve. Ou une incompatibilité mystérieuse. Peut-être à cause de tes précédentes tentatives.

Sinon, comme a dit Eldrak, essaies sur une config différente (windows 7). Nous n'avons pas encore fait des masses de tests avec Windows 10.

Tiens nous au jus.

Link to post
Share on other sites
  • 0

J'ai bien suivi le tuto, le FixT s'installe bien au bon endroit.

Je pense pas que ça vienne des précédentes tentatives, sur l'autre ordi j'ai juste testé avec l'installation manuelle.

Je voulais tester sur un vieux XP, mais j'arrive plus à le démarrer.... l'alimentation a dû me lâcher.

Je testerai chez un ami un peu plus tard. Je vous dirai.

 

Merci

Link to post
Share on other sites
  • 0

Voilà les screens de mon installation manuelle. J'ai mis le fixT en version de base cette fois ci, pas en version complète.

J'ai aussi contacté Bethesda, dans leur première réponse ils me disaient de faire les choses de base (mode administrateur, compatibilité, mettre à jour la carte graphique, ...). Dans leur second mail ils me demandaient mon msinfo32. J'attends leur réponse.

Fallout_01.jpg

Fallout_02.jpg

 

EDIT : Dernière réponse de Bethesda : ils ne peuvent rien faire, il y a souvent des problèmes avec des vieux jeux comme ça (merci bethesda...). Ils me proposent 2 solutions "non officielles" en s'excusant de pas avoir mieux :

http://www.wikihow.com/Install-a-High-Resolution-Patch-to-Fallout-1-from-Steam

http://forums.steampowered.com/forums/showthread.php?t=1591477

Dans le doute, j'ai quand même réessayé, toujours la même chose. Dès que j'ai accès à un autre ordi, j'essaierai mon installation.

Edited by mkael
Link to post
Share on other sites
  • 0

:biggrin: Je suis même surpris de leur rapidité de réponse, c'est quasiment du tac au tac, pour ça il n'y a rien à dire.

Je viens de pense à VirtualBox, j'essaierai de faire une émulation de xp ou seven pour tester.

Link to post
Share on other sites
  • 0

Je reviens un peu tard, désolé.

J'ai enfin pu prendre ton fichier Hekan et... Bon dieu mais ça marche !!!!! J'ai placé ton dossier directement dans le dossier c:\Games et j'ai lancé le falloutW.exe du FixT et le jeu démarre.

Le problème devait donc bien venir de mon installation mais je ne vois pas d'où... je me pencherai dessus pour essayer de trouver d'où vient la différence par rapport à ton installation (je n'aime pas ne pas savoir).

Merci bien pour ton dossier en tout cas. Tu as mis le FixT en complet sur ton installation ?

Et merci à vous tous pour votre aide.

Link to post
Share on other sites
  • 0

Content que ça fonctionne !

 

Citation

Utilise Winmerge pour controler les différences entre deux dossiers ! 

En effet, Winmerge pourra te renseigner.

 

Citation

Le problème devait donc bien venir de mon installation mais je ne vois pas d'où... je me pencherai dessus pour essayer de trouver d'où vient la différence par rapport à ton installation (je n'aime pas ne pas savoir).

Si possible, redis nous.

Link to post
Share on other sites
  • 0

Bon et bien après plusieurs tests, ça reste très bizarre...

J'ai refais une installation complète dans le dossier steam avec le FixT FR. En le copiant dans Games ça ne marche pas. Par contre en le mettant dans un dossier sur le bureau j'ai réussi à le démarrer (enfin !).

J'arrive à le faire fonctionner dans certains dossiers et pas dans d'autres. Par contre maintenant en mettant le dossier de Hekan dans Games je n'arrive plus à lancer son installation, alors que ça marchait avant.

C'est peut-être un conflit au niveau des clés registre non ?

En tout cas j'arrive enfin à le lancer. J'essaierai pour le 2 et je referai d'autres tests plus tard quand j'aurai plus de temps (après un nettoyage avec CCleaner notamment)

 

Merci à tous

 

PS : j'ai pas eu le temps non plus de contrôler avec winmerge, je verrai plus tard

Link to post
Share on other sites
  • 0

C'est bizarre ^^.

Ton dossier Games est dans la même partition que Windob ? Fais un nettoyage de ton registre ?

Après si tu as refait une install complète et que ça a fonctionné le tuto dois être bon.

Sur ce : Bon jeu !

Link to post
Share on other sites
  • 0

Je reviens pour donner un peu des nouvelles, si ça peut aider quelqu'un.

Concernant Fallout 1 tout est ok. J'ai désinstallé complétement le patch et le jeu (après avoir copié le dossier complet bien évidemment). Du coup tout marche, même dans le dossier Games.

Pour résumer, j'ai donc fait une installation complète du jeu avec steam, installé le FixT et le patch FR, copié le dossier Fallout ailleurs, puis tout désinstallé. Ça a fonctionné comme ça.

 

Pour Fallout 2, j'ai essayé le même système. C'est à dire installer le jeu steam, mettre le PNO puis le Patch FR. Ensuite copier le dossier et désinstaller le PNO et le jeu. J'ai pas encore réussi à le faire fonctionner sur l'ordi où j'avais installer le jeu (même en faisant du nettoyage dans le registre). Mais par contre, j'ai copié le dossier sur une clé usb pour l'essayer sur l'autre ordi qui a la même config que le mien (avec windows 10) et là le jeu se lance sans problème.

Je ne comprends pas pourquoi ça bug lorsque je fais une installation du jeu... Il y a surement un conflit quelque part mais je n'ai pas réussi à trouver où pour le moment.

 

Si jamais j'arrive à résoudre ça, je vous tiendrai au courant.

Link to post
Share on other sites
  • 0

Tout supprimé proprement oui.

D'abord j'ai désinstallé le jeu par steam, puis redémarré, puis supprimé le dossier du jeu dans le dossier steamapps et dans Appsdata. J'ai ensuite fait un nettoyage du registre avec ccleaner.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.